$re = '/@(\d+)(?=@)/m';
$str = '@432432@Hi@534543534@
@432432@333@534543534@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);