#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*, )|(\..*)"
Local $sString = "Stengel, Mrs. Charles Emil Henry (Annie May Morris)" & @CRLF & _
"Barry, Miss. Julia" & @CRLF & _
"Leader, Dr. Alice (Farnham)" & @CRLF & _
"Butt, Major. Archibald Willingham" & @CRLF & _
"Goodwin, Master. Harold Victor" & @CRLF & _
"Stankovic, Mr. Ivan"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")