import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*, )|(\\..*)";
final String string = "Stengel, Mrs. Charles Emil Henry (Annie May Morris)\n"
+ "Barry, Miss. Julia\n"
+ "Leader, Dr. Alice (Farnham)\n"
+ "Butt, Major. Archibald Willingham\n"
+ "Goodwin, Master. Harold Victor\n"
+ "Stankovic, Mr. Ivan";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}