// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*, )|(\..*)").unwrap();
let string = "Stengel, Mrs. Charles Emil Henry (Annie May Morris)
Barry, Miss. Julia
Leader, Dr. Alice (Farnham)
Butt, Major. Archibald Willingham
Goodwin, Master. Harold Victor
Stankovic, Mr. Ivan";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}