re = /^\w+\s+(\d+\s+-\s+([^\-\s]+(\s+[^\-\s]+)*))(\s+-.*)?$/m
str = 'Opcao 06 invalida - nao corresponde ao formato123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end