$re = '/^[A-Z0-9_]+$/m';
$str = 'MY_VARIABLE_NAME
CAN_INCLUDE_NUMB3R5
BUT_THIS~IS_NOT_OK
🦄
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);