using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"name=""(.{6})"" id="".{6}"" value=""(.{43})""";
string input = @"<input type=""hidden"" name=""Yw55vQ"" id=""Yw55vQ"" value=""06kcaY4_oXjDY-CB5lvTyk6edgWgn6qEuo2mMFvDfmE"" />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}