package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)name="(.{6})" id=".{6}" value="(.{43})"`)
var str = `<input type="hidden" name="Yw55vQ" id="Yw55vQ" value="06kcaY4_oXjDY-CB5lvTyk6edgWgn6qEuo2mMFvDfmE" />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}