const regex = /name="(.{6})" id=".{6}" value="(.{43})"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('name="(.{6})" id=".{6}" value="(.{43})"', 'gm')
const str = `<input type="hidden" name="Yw55vQ" id="Yw55vQ" value="06kcaY4_oXjDY-CB5lvTyk6edgWgn6qEuo2mMFvDfmE" />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}