use strict;
my $str = '<input type="hidden" name="Yw55vQ" id="Yw55vQ" value="06kcaY4_oXjDY-CB5lvTyk6edgWgn6qEuo2mMFvDfmE" />';
my $regex = qr/name="(.{6})" id=".{6}" value="(.{43})"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}