package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^([a-z]*\.[a-z]*|[a-z]+)$`)
var str = `abc
a.cd
.
a
Not:
a.a.a
.a.
..
a#a
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}