import Foundation
let pattern = #"^(RSUINTREL-[0-9]+\s+|PANGUSW-[0-9]+\s+|APRICOT-[0-9]+\s+|GEN6PANGU-[0-9]+\s+|SWFCN-[0-9]+\s+)+.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ####"""
### Should Pass Test
SWFCN-287 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
SWFCN-287 APRICOT-9999 SWFCN-0000 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
APRICOT-287 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
SWFCN-287 debug 222 test test test !!!!
GEN6PANGU-1111 Add gitlab ci
RSUINTREL-957 add test message
### Failed to match test
SWFCN-2a7 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
SWFCN-287APRICOT-9999 SWFCN-0000 debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
debug CI_MERGE_REQUEST_SOURCE_BRANCH_NAME
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)