package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/([^/.]+)$`)
var str = `www.mysite.com/page
www.mysite.com/doc1/doc2/page
www.mysite.com/page/
www.mysite.com/file.php
www.mysite.com/file.jpg
www.mysite.com/file.html
www.mysite.com/file.doc`
var substitution = "/\1/"
fmt.Println(re.ReplaceAllString(str, substitution))
}