// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)/([^/.]+)$").unwrap();
let string = "www.mysite.com/page
www.mysite.com/doc1/doc2/page
www.mysite.com/page/
www.mysite.com/file.php
www.mysite.com/file.jpg
www.mysite.com/file.html
www.mysite.com/file.doc";
let substitution = "/\\1/";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}