re = /^(\d+),([a-zA-Z]+(?: [a-zA-Z]+)*),/m
str = 'Address Number,Name,Employee Master Exist(Y/N),Auto-Deposit Exists(Y/N),Supplier Master Exists(Y/N),Supplier Master Created,ACH Account Exists(Y/N),ACH Account Created,ACH Same as Auto-deposit(Y/N)
4398,Presley Elvis Aaron,Y,N,Y,N,Y,N,N
10154,Shepard Alan Barrett,Y,Y,Y,N,Y,N,N'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end