package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9a-fA-F]{20,}`)
var str = `commit_message = "commit d1099308a1af0f91e93bf22cf6e9b5d294cf121d Author: Martin Date: Wed Apr 17 16:05:35 2019"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}