# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)^.+\bCurrent: ([\d.]+).+\bLatest: ([\d.]+).*$"
test_str = ("GAMADV-XTD3 6.07.31 - https://github.com/taers232c/GAMADV-XTD3 - pyinstaller\n"
"Ross Scroggs <ross.scroggs@gmail.com>\n"
"Python 3.9.7 64-bit final\n"
"Windows 10 10.0.18363 SP0 Multiprocessor Free AMD64\n"
"Path: C:\\GAMADV-XTD3\n"
"Config File: C:\\GAMConfig\\gam.cfg, Section: DEFAULT, customer_id: C047encoi, domain: sonos.com \n"
"Version Check:\n"
" Current: 6.07.31\n"
" Latest: 6.07.31\n")
subst = "$1 $2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.