package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?<scope>@[\d*a-z~-][\w*.~-]*)\/)?[\da-z~-][\w.~-]*$`)
var str = `mlly
@flex-development/mlly
@npm/thingy
crazy!
.start-with-period
@npm-zors/money!time.js
@FLEX-DEVELOPMENT/MLLY
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}