import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?<scope>@[\\d*a-z~-][\\w*.~-]*)\\/)?[\\da-z~-][\\w.~-]*$";
final String string = "mlly\n"
+ "@flex-development/mlly\n"
+ "@npm/thingy\n"
+ "crazy!\n"
+ ".start-with-period\n"
+ "@npm-zors/money!time.js\n"
+ "@FLEX-DEVELOPMENT/MLLY\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}