$re = '/^(?:(?<scope>@[\d*a-z~-][\w*.~-]*)\/)?[\da-z~-][\w.~-]*$/m';
$str = 'mlly
@flex-development/mlly
@npm/thingy
crazy!
.start-with-period
@npm-zors/money!time.js
@FLEX-DEVELOPMENT/MLLY
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);