const regex = /(?<=\bkey=")(?=.*-xyz(?=-|$))abcd(?:-[a-z]+)+(?=")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\bkey=")(?=.*-xyz(?=-|$))abcd(?:-[a-z]+)+(?=")', 'gm')
const str = `I found the key="abcd-qwer-qaa-xyz-vwxc" to salvation
I found the key="abcd-qwer-qaa-xy-vwxc" to salvation
I found the key="abc-qwer-qaa-xyz-vwxc" to salvation
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}