$re = '/-?\d+/';
$str = 'a=<-1,4342,-3> b=<4443,-5,6>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);