const regex = /^([\S\s]+?)\s+([\d-\s]*?)\s*([\w])?$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\S\\s]+?)\\s+([\\d-\\s]*?)\\s*([\\w])?$', 'gim')
const str = `Teststraße 1-5a
Teststraße 5 a
Test Von Tobel Strasse 13 - 16 a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}