re = /(\b)-\n(\b)/m
str = 'Test test test te-
st test test.
Zażółć gęślą jaźń, zażółć gęś-
lą jaźń.
— Pchnąć w tę łódź je-
ża i óśm skrzyń fig! — A po co, a dla kogo!
— Wszyscy gl*niarze to s*kinsyny!
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result