package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?<.*?<(hhDate)>(\d+-\d+-\d+).*$`)
var str = `<abcdefghkdadajsdkdjg><hhDate>2019-12-31 <dklajdlajdkjasd>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}