#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(\d+,\s?)*(\d+)$"
Local $sString = "12345" & @CRLF & _
"" & @CRLF & _
"1, 34, 12345, 5063" & @CRLF & _
"" & @CRLF & _
"1 34 12345 5063" & @CRLF & _
"" & @CRLF & _
"1, " & @CRLF & _
"" & @CRLF & _
"0," & @CRLF & _
"" & @CRLF & _
"abscolkjs, js334, 5p3, 42324"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")