import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+,\\s?)*(\\d+)$";
final String string = "12345\n\n"
+ "1, 34, 12345, 5063\n\n"
+ "1 34 12345 5063\n\n"
+ "1, \n\n"
+ "0,\n\n"
+ "abscolkjs, js334, 5p3, 42324";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}