const regex = /^(\d+,\s?)*(\d+)$/mgi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+,\\s?)*(\\d+)$', 'mgi')
const str = `12345
1, 34, 12345, 5063
1 34 12345 5063
1,
0,
abscolkjs, js334, 5p3, 42324`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}