re = /^(\d+,\s?)*(\d+)$/mi
str = '12345
1, 34, 12345, 5063
1 34 12345 5063
1,
0,
abscolkjs, js334, 5p3, 42324'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end