// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(\d+,\s?)*(\d+)$").unwrap();
let string = "12345
1, 34, 12345, 5063
1 34 12345 5063
1,
0,
abscolkjs, js334, 5p3, 42324";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}