import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[-#+]*(?:[0-9]+[-\\s]*)?\\(?[0-9]{1,4}\\)?(?:[-\\s./]*[0-9])*";
final String string = "can i make a call to +21231313\n"
+ "can i make a call to -21231313\n"
+ "can i make a call to 21231313\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}