re = /(?s)<logicalIdentifier>(?<Identifier>.+?)(?=<).+?<status>(?<Status>.+?)(?=<)/m
str = ' <logicalIdentifier>1234-YYYMMDD</logicalIdentifier>
<status>Accepted</status>
<logicalIdentifier>2345-YYYMMDD</logicalIdentifier>
<status>Accepted</status>
<logicalIdentifier>3456-YYYMMDD</logicalIdentifier>
<status>Accepted</status>
<logicalIdentifier>4567-YYYMMDD</logicalIdentifier>
<status>Accepted</status>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end