package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\s*)(,?)"([a-zA-Z0-9]+?)":(\s*)"([a-zA-Z0-9]+?)"`)
var str = `{"key1": "value1", "key2": "value2"} `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}