import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<w>\\d+)[.](?P<x>\\d+)[.](?P<y>\\d+)-(?P<z>android\\d+)-(?P<k>\\d+).*$";
final String string = "5.4.42-android12-0-00544-ged21d463f856";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}