re = /^(?P<w>\d+)[.](?P<x>\d+)[.](?P<y>\d+)-(?P<z>android\d+)-(?P<k>\d+).*$/m
str = '5.4.42-android12-0-00544-ged21d463f856'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end