# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=<tag[^>]*?type=["']findMe["'])/\n[break]\n/g;t' <<< "some html text <br> with some formatting<tag id=\"1\" type=\"dontFidMe\">sample text</tag> yada <tag id=\"2\" type=\"findMe\">sample text</tag>yada"