#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?=<tag[^>]*?type=["']findMe["'])"
Local $sString = "some html text <br> with some formatting<tag id="1" type="dontFidMe">sample text</tag> yada <tag id="2" type="findMe">sample text</tag>yada"
Local $sSubst = "\n[break]\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)