$re = '/^[\w]+([-_\s]{1}[a-z0-9]+)*$/m';
$str = '_______';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);