import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\B#([\\p{L}\\p{N}_]+)(?!#)\\b";
final String string = "https://google.com/#test #asdasd\n\n"
+ "#test\n\n"
+ "#你好\n"
+ "#asdasdasd .#asdasd #asdasd#asdasd\n\n"
+ "Works well for most languages. And requires a space in front.\n\n"
+ "##no <-- not allowed which is good.\n"
+ "#yes\n\n"
+ "#güneş\n\n"
+ "#günşöhlesi\n\n"
+ "Not sure why some say languages like the one above doesn't work...\n\n"
+ "https://github.com/justoverclockl/flarum-ext-hashtag####hashtag\n"
+ "#asdasd.\n\n"
+ "#123123123+asdasd";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}