# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\B#([\p{L}\p{N}_]+)(?!#)\b"
test_str = ("https://google.com/#test #asdasd\n\n"
"#test\n\n"
"#你好\n"
"#asdasdasd .#asdasd #asdasd#asdasd\n\n"
"Works well for most languages. And requires a space in front.\n\n"
"##no <-- not allowed which is good.\n"
"#yes\n\n"
"#güneş\n\n"
"#günşöhlesi\n\n"
"Not sure why some say languages like the one above doesn't work...\n\n"
"https://github.com/justoverclockl/flarum-ext-hashtag####hashtag\n"
"#asdasd.\n\n"
"#123123123+asdasd")
matches = re.finditer(regex, test_str, re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.