#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b([a-z])\1+(?!\1|\b)|(?<=([a-z]))((?!\2)[a-z])\3+"
Local $sString = "aaa baaab xxx" & @CRLF & _
"ahhj aaab cc iiik" & @CRLF & _
"bbb ahhj aaab cc iiik xxx fjjj baaaaaab yyyaaa"
Local $sSubst = "$1$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)