# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\ba[^ex]*?a\b/!/gm;t' <<< "Есть исходник, не совсем удобный:
\"aba aea aca aza axa a-a a#a\""