// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\ba[^ex]*?a\b").unwrap();
let string = "Есть исходник, не совсем удобный:
\"aba aea aca aza axa a-a a#a\"";
let substitution = "!";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}