import Foundation
let pattern = #"\ba[^ex]*?a\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Есть исходник, не совсем удобный:
"aba aea aca aza axa a-a a#a"
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"!"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)