# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(==.+\s(?:[\*][\s].+\s)+)/\1{{template}}\n/g;t' <<< "== See Also ==
* [[Link one]]
* [[more link]]
* [//external.link external link]
* [//external.link more link]
[[Category:Pages]]
[[de:Spezial Page]]"