const regex = /(==.+\s(?:[\*][\s].+\s)+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(==.+\\s(?:[\\*][\\s].+\\s)+)', 'g')
const str = `== See Also ==
* [[Link one]]
* [[more link]]
* [//external.link external link]
* [//external.link more link]
[[Category:Pages]]
[[de:Spezial Page]]`;
const subst = `\1{{template}}\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);