package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Task \d - (\w+)\n`)
var str = `Task 1 - complete
Task 2 - ongoing
Task 3 - planned
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}