$re = '/^[a-zA-Z0-9]\.[a-zA-Z0-9]+@example\.com$/';
$str = 'a.test@example.com';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;