#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)\{\{window\.location\.(.+?)\}\}"
Local $sString = "1. this isa (test)" & @CRLF & _
"2. tis is a {{test}}" & @CRLF & _
"3. thisis a {{instance.test}}" & @CRLF & _
"4. thisis a {{instance.something}}" & @CRLF & _
"5. this is a {{window.location.hostname}} {{window.location.protocol}} "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")