package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\{\{window\.location\.(.+?)\}\}`)
var str = `1. this isa (test)
2. tis is a {{test}}
3. thisis a {{instance.test}}
4. thisis a {{instance.something}}
5. this is a {{window.location.hostname}} {{window.location.protocol}} `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}